Announcement

Collapse
No announcement yet.

Yilmaz - Import External Images vB5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Font Size
    #1

    vB5.X.X Yilmaz - Import External Images vB5

    Description:

    This vBulletin 5 product imports external images in your posts from external servers or paths into a specific path, normally your forum's image folder.

    How to install :
    ======================================
    Upload the content of "Yilmaz - Import External Images vB5" to your root.
    that's all it.
    enjoy..

    How to uninstall:
    ======================================
    1. Remove the package "yilmaziei5" that located in /core/packages/
    2. Go to "Manage Products" in the admincp and delete the product named "Yilmaz - Import External Images vB5"
    Attached Files
    Similar Threads

  • Font Size
    #2
    Hey, good job! One question, would it be possible to name the pics like the thread name?


    Greetings friend!
    yilmaz likes this.

    Comment


    • Font Size
      #3
      Wow, thank you verry much for this. Was looking for such a mod.

      Thanks
      yilmaz likes this.

      Comment


      • Font Size
        #4
        Hi Yilmaz, got a question.

        I installed it like you said.
        But when i check if it works and saves it on my server i get this :

        "[IMG2=JSON]{"data-align":"none","data-size":"full","src":"https:\/\/lumiere-a.akamaihd.net\/v1\/images\/darth-vader_6bda9114_e7820538.jpeg?region=0%2C70%2C1400% 2C788"}[ /IMG2]"

        It does not give the URL of my forum/server.
        Checked the "imported" folder on the server, and no pictures saved there.

        Anything i do wrong?

        Thank you

        Comment


        • Font Size
          #5
          Last edited by yilmaz; 16-02-2021, 08:56.

          Comment


          • Font Size
            #6
            Hi Yilmaz,

            Been awhile due some personal problems.
            However, still working on this mod to get it work.
            Installed it, as explained above, and the same problem keeps coming back.
            The pictures are stored like this :

            [ IMG2=JSON]{"data-align":"none","data-size":"full","src":"https:\/\/images0.persgroep.net\/rcs\/fXCLrk4pUeEZ464Mz_m8fYgJMVg\/diocontent\/154505890\/_fitwidth\/694\/?appId=21791a8992982cd8da851550a453bd7f&quality=0. 8"}[/IMG2 ]

            And it does not make a "forum URL" and save it on the server. The folder images/imported is at 777 , but nothing is saved there when mod is installed and activated.

            Can you please help me?

            Regards

            Comment


            • Font Size
              #7
              Deniz.... put a final user interface print screen picture.. maybe useful!

              Comment


              • Font Size
                #8
                Originally posted by mito22 View Post
                Deniz.... put a final user interface print screen picture.. maybe useful!
                Hi there,
                Sorry do not know what you mean by that.
                From what do you want a printscreen?

                Greets

                Comment


                • Font Size
                  #9
                  Is there anyone who could help me with this?

                  Searched it on google, and turns out json = java?
                  could that be the problem?
                  Last edited by adama; 20-04-2021, 06:59.

                  Comment


                  • Font Size
                    #10
                    Allright, diggin in to it a bit deeper and found this.

                    When you use the img bb-code in vb5, it automaticaly parses the linkt to img2=json.
                    Apparently this is now the way vbulletin uses images instead of the old img- bb-code.
                    So i think this is the reason why the mod is not working, beceause it wants to use the url from the img-bb-code and vbulletin is changing it to img2=json.

                    I am not a coder, but i am thinking this:
                    The mod actually should parse the img2=joson code to a new board url and save the picture, and save that link in the topic.

                    Is this possible, and do you coders have enough info of what i mean?

                    Comment


                    • Font Size
                      #11
                      Installed and works great.


                      I have over a million images on my site, Therefore, I cannot store these images in the same domain for ease of backing up.

                      So can I specify a folder path on my server "NOT FOLDER NAME":

                      Example:
                      Code:
                      /home/user2/public_html/store/
                      Just as the same way of attachment storage method
                      Example:


                      Very grateful for your kindness.

                      Last edited by Damas; 22-04-2021, 01:26.

                      Comment


                      • Font Size
                        #12
                        Originally posted by yilmaz View Post
                        Hi,

                        This test you did, also links to another site.
                        It has not a link to your own server where the picture is stored.

                        Can you help please?

                        Thank you very much

                        Comment


                        • Font Size
                          #13
                          Originally posted by adama View Post

                          Hi,

                          This test you did, also links to another site.
                          It has not a link to your own server where the picture is stored.

                          Can you help please?

                          Thank you very much
                          1- Go to Themes [Add New Replacement Variable‎]‏

                          2- [Add New Replacement Variable‎]








                          Comment


                          • Font Size
                            #14
                            Originally posted by Damas View Post

                            1- Go to Themes [Add New Replacement Variable‎]‏

                            2- [Add New Replacement Variable‎]







                            I can do this.
                            However, the picture is not stored in the imported folder on my server.
                            That is the problem, is will not even save on the server.
                            For some reason it will not parse.
                            Folder on server is at 777

                            This is wat i get:

                            [IMG2=JSON]{"data-align":"none","data-size":"full","src":"https:\/\/imgup.nl\/images\/2021\/04\/22\/picard.jpg"}[ /IMG2]

                            And it will not parse to : https://www.domain.com/images/imported/picard.jpg
                            And it will not save the picture in the folder.

                            Installed the mod exactly as said above.
                            The mod is not working as the way it works on vb4, have build a lot of vb4 forums for friends.
                            Always used this hack and no problem, only with vb5.....
                            Hope you guys can help me.

                            Regards en thank you for all your help

                            Comment


                            • Font Size
                              #15
                              OK.....

                              Still busy with this.
                              I am a bit closer of what the problem is.
                              What i said above about the IMG2=JSON we can scrap that!!! That is after serious research not the problem.
                              The problem is the parsing proces itself.
                              When i make a new topic, put the picture in, then it takes often a long time that the picture is parsed.
                              One is taking 10 minutes when it is parsed and stored on the server.
                              Another one takes about a hour of 2.
                              And sometimes it does parse after 24 hours, and sometimes it does not.

                              So it is working a little, only the parsing proces is not working correctly.
                              In VB4 where i have this also for years, it parses imediatly when you post the topic with the picture.

                              Hope Yilmaz or someone can help me with this.

                              Regards and thanks

                              Comment

                              X

                              Thread Information

                              Collapse

                              Users Browsing this Thread

                              There are currently 3 users browsing this thread. (0 members and 3 guests)

                                Those who read this thread

                                Collapse

                                Members who have read this thread: 3

                                Working...
                                X

                                AdBlock Detected

                                Please Disable Adblock

                                Please consider supporting us by disabling the ad blocker.

                                I've Disabled AdBlock
                                0x0